Dark Light

Browser issues

Some issues with Wagtail may come from the browser. Try clearing the browser cache and cookies, or you can also try using Wagtail with another browser to see if the problem persists.

JavaScript is required to use Wagtail – make sure it is enabled in your browser.

Supported browsers

For the best experience and security, we recommend that you keep your browser up to date. Go to Browse Happy for more information.

IE11

Wagtail has officially removed support for the legacy Internet Explorer browser in version 2.15.

  • In Wagtail 2.11 (LTS), there was be a warning message displayed on the Wagtail dashboard for IE11 users with administrator role.
  • In Wagtail 2.12, the message was displayed to all users regardless of their role.
  • In Wagtail 2.13 and 2.14, the message was displayed at the top of all pages.
  • Wagtail 2.15 and beyond don’t support IE11.
  • Starting in Wagtail 2.16, there is no warning message for users.

If this affects you or your organisation, consider which alternative browsers you may be able to use. Wagtail is fully compatible with Microsoft Edge, Microsoft’s replacement for Internet Explorer. You may consider using its IE mode to keep access to IE11-only sites, while other sites and apps like Wagtail can use modern browser capabilities.

Assistive technologies

We want Wagtail to be accessible for users of a wide range of assistive technologies, but are aware of many blockers currently. For an overview, see our public accessibility audit.